问题描述:

Is neo4j 2.0 exclusively for jdk 7 ? Our firm runs on jdk 1.6 and we can not upgrade to jdk 7 till next year.

Any way to make it work?

网友答案:

Based on the release notes it looks like Java 7 is required:

2.0.0-M04
---------
Kernel:
  o BREAKING CHANGE: Require Java 7

I'm not a Neo4j developer, but based on Java developer experience in general, when a major dependency update like this is introduced, I find it unlikely to be rolled back.

相关阅读:
Top