问题描述:

This question already has an answer here:

  • Can't install gems on OS X “El Capitan”

    13 answers

网友答案:

I had the same problem after upgrading to OS X El Capitan (10.11), but while trying to sudo gem install sass. The poster's solution of putting the path in the install command worked for me, and installing compass also installs sass, so: sudo gem install -n /usr/local/bin compass did the trick. Thanks Leo!

网友答案:

The fix I found was simply to put the PATH in the install command for any ruby gem package:

$  sudo gem install -n /usr/local/bin GEM_PACKAGE_NAME

So with compass it worked for me as:

$ sudo gem install -n /usr/local/bin compass

Good Luck!

相关阅读:
Top