问题描述:

How do I manually install a plugin in Eclipse? Or how do I force the installer to install a plugin, even when it doesn't want to?

E.g., I am trying to downgrade a plugin (an update for which contained a bug that I cannot work with). I have tried going to About Eclipse -> Installation Details -> Installation History and selecting a previous configuration, but I get errors trying to revert to one. I have also downloaded the all-in-one update for the previous version of the plugin I want to roll-back. But if I go to Install New Software -> Add -> Archive then I can select the update, but when I try to install it I am told that the plugin I'm trying to install "will be ignored because a newer version is already installed".

I need a way to install the plugin manually or force the installer to install the older version of the plugin. Doe anyone know how this can be achieved?

网友答案:

You should uninstall the current version of the plug-in before installing the older one. go to About Eclipse -> Installation Details -> Installed Software and uninstall the plug-in you want to downgrade. then try again installing it going toInstall New Software -> Add -> Archive...

saluti

网友答案:

There is some difference between each Eclipse version to locate the feature. Which version did you use ? 3.3 ?

I can't say where you will find the option but start by removing the installedv ersion and retry to install the older.

If you realy want to install it you can also try to find the archive and extract the content into your Eclipse folder (It may have two folder features and plugin).

/!\Take care about plugin dependency and compatibilty/!\ Make a backup of your installation before.

网友答案:

You should remove the top level plugin.

Try to reinstall it without selecting the last version of the plugin. May be you can select and older version in this step or install the expected sub-plugin version later.

Or

Find which version of "epp.package.php" use the plugin version you need. Install it. And if needed try to update some plugin/sub-plugin and check if your sub-plugin is not in the update list.

相关阅读:
Top