问题描述:

I've recently installed Visual Studio Community 2015 and I've been following an MSDN tutorial "Build cross-platform apps with Xamarin". When its time to design the look of the app and I select the Main.axml file in the Resources\layout folder, the Android designer fails with:

The installed Android SDK is too old. Version 24.3.4 or newer is required. Please update to the latest version.

I've done a lot of searching and found that one of the newer versions of Android SDK caused the Xamarin Android designer to fail. I did find a version 24.4.1 that suggests this designer problem is fixed.

How do I update this part of Visual Studio (i.e. Xamarin.Android)? Here is a snippet of my install on Windows 7:

网友答案:

Tools --> Options --> Xamarin

Under "iOS Settings" and "Android Settings" there is a link for "Check Now" next to the Updates settings

网友答案:

You might want to update to Beta release if you need the latest components -

Goto VS 2015 -> Tools -> Option -> Xamarin -> Others -> Check Now

网友答案:

In newer Version of Visual studio this option is available in Other node

Goto VS 2015 -> Tools -> Options -> Xamarin -> Other -> Check Now

Here you can choose between Alpha, Beta or Stable versions of xamarin for Visual Studio.

网友答案:

They moved the "Check Now" into the harder-to-find Tools/Options/Xamarin/Other. We must always be on guard when dealing with the

Other

网友答案:

Apparently, my problem was solved after installing SDK Platform for Android 6.0 or API 23. API 24 or higher i.e Android 7.0 (Nougat) didnt run. If still not solved then install SDK Platform for even lower APIs like 22,21 ... Hope it helps.

相关阅读:
Top