问题描述:

I installed foundation 6 using bower-rails on a Rails app (Rails v4.2.6).


Imported it in my css via

@import 'foundation-sites/scss/settings/settings';

@import 'foundation-sites/scss/foundation';

I get this error when I load the page

Sass::SyntaxError in Controller#action

Invalid CSS after "...-flexbox: true ": expected "}", was "!global;"

When I import the plain css files, it works but displays this error when I import the sass files.

Am I missing something?

网友答案:

Foundation 6 uses latest Sass syntax like '!global'.

Updating sass to the latest version should do the trick.

$ gem update sass

Hope that helps.

相关阅读:
Top