问题描述:

When I open emacs, the following messages appear in the *Messages* buffer, and my init.el file (located at ~/.emacs.d/init.el) doesn't load.

Loading 00debian-vars...done

Loading /etc/emacs/site-start.d/50cedet-common.el (source)...

Error while loading 50cedet-common: Cannot open load file: cedet-autogen

Loading /etc/emacs/site-start.d/50dictionaries-common.el (source)...

Loading debian-ispell...

Loading /var/cache/dictionaries-common/emacsen-ispell-default.el (source)...done

Loading debian-ispell...done

Loading /var/cache/dictionaries-common/emacsen-ispell-dicts.el (source)...done

Loading /etc/emacs/site-start.d/50dictionaries-common.el (source)...done

Loading /etc/emacs/site-start.d/50haskell-mode.el (source)...

Loading /usr/share/emacs/site-lisp/haskell-mode/haskell-site-file.el (source)...done

Loading /etc/emacs/site-start.d/50haskell-mode.el (source)...done

Loading /etc/emacs/site-start.d/50php-elisp.el (source)...done

Loading /etc/emacs/site-start.d/51speedbar.el (source)...done

For information about GNU Emacs and the GNU system, type C-h C-a.

I can't find any helpful information about cedet when I google it or look on the emacs wiki. Oddly, when I use M-x eval-buffer or M-x load-file, everything works fine. HOME is what it should be, and I'm running version 23.3.1.

I had been trying to get jshint working with emacs before this happened, though I'm not sure if that's at all relevant https://github.com/daleharvey/jshint-mode.

网友答案:

Remove the ~/.emacs file first. See Emacs Wiki for more detail.

相关阅读:
Top