问题描述:

Current desktop application is developed using PowerBuilder version 9 with Oracle 9.2 as a back end. Now I need to migrate the back end Oracle to 11.2.0.2. From Googling I found PowerBuilder 9 is no longer supported. Is it possible to connect to Oracle 11.2.0.2 with PB 9? Kindly let me know if I can migrate the same application to higher version of PB like PB 11?

网友答案:

If you look at this response from Terry Dykstra you'll see your options under PB9 are:

the O90 driver, ODBC, OLEDB or JDBC

As for migrating to a higher version, migrating to higher versions of PB are typically comparatively small efforts (but no guarantees), assuming you have all the source code.

You mention upgrading to PB11. Keep in mind that PB11 also is no longer supported. Sybase (now an SAP company) typically supports current and previous major versions (with some overlap), so right now that means 12.5 and 12.0.

Good luck,

(another) Terry

相关阅读:
Top