问题描述:

When writing application to run on Apache Spark 1.6 using Elasticsearch-Spark connector, documentation at (https://www.elastic.co/guide/en/elasticsearch/hadoop/5.0/install.html#_minimalistic_binaries) says to use maven artefact

<dependency>

<groupId>org.elasticsearch</groupId>

<artifactId>elasticsearch-spark_2.10</artifactId>

<version>5.0.0</version>

</dependency>

However maven fails with error message that specified artefact cannot be found. After searching through maven central I found however alternative versions:

For Spark 1.3+

 <dependency>

<groupId>org.elasticsearch</groupId>

<artifactId>elasticsearch-spark-13_2.10</artifactId>

<version>5.0.0</version>

</dependency>

For Spark 2.*

 <dependency>

<groupId>org.elasticsearch</groupId>

<artifactId>elasticsearch-spark-20_2.10</artifactId>

<version>5.0.0</version>

</dependency>

网友答案:

Ah, got the answer from ES folks. It is a bug in documentation, going to be fixed soon. https://github.com/elastic/elasticsearch-hadoop/issues/890#issuecomment-258511400

相关阅读:
Top