问题描述:

I am on a 64bit Fedora 17 box, PHP5.4.8. I have Oracle Instant Client 11.2 installed. I am trying to install the pdo_oci package and I'm running into some issues.

I have the latest PDO_OCI package. I unpacked it and executed the following:

~$ > cd ../PDO_OCI-1.0

~$ > phpize

~$ > ./configure --with-pdo-oci=instantclient,/usr/lib/oracle/11.2/client64/lib

I get the error message:

"I'm too dumb to figure out where the include dir is in your instant client install"

As suggested by the pdo_oci manual in php.net, I created couple of paths with the minor version of the OIC as such

ln -s /usr/bin/include/oracle/11.2 /usr/include/oracle/11.2.0.1

Still I get the same error message. Does anybody have any idea?

The machine I'm running this on is not connected to the internet, so I have to run the installation using the previously downloaded packages.

网友答案:

I was running into the same problem. I an running centos 6.5 64bits, but fedora is a lot similar.

Supposing you already installed both basic and devel packages:

oracle-instantclient11.2-basic-11.2.0.4.0-1.x86_64.rpm oracle-instantclient11.2-devel-11.2.0.4.0-1.i386.rpm

You should specify just the "/usr" directory, as the configure looks for oci.h in this way in configure:

$PDO_OCI_IC_PREFIX/lib/oracle/$PDO_OCI_IC_VERS/client/include/oci.h

so, after editing config.m4 to be able to do a 11.2 install (reference for the url in the end), do this:

./configure --with-pdo-oci=instantclient,/usr,11.2

I followed this tutorial:

http://shiki.me/blog/installing-pdo_oci-and-oci8-php-extensions-on-centos-6-4-64bit/

相关阅读:
Top