问题描述:

I get the errors below when I run npm install -g yo on my windows command line. Any ideas on what I need to do to get a clean install of Yeoman?

C:\Users\zmacomber\AppData\Roaming\npm\bower -> C:\Users\zmacomber\AppData\Roaming\npm\node_modules\bower\bin\bower

npm ERR! peerinvalid The package yo does not satisfy its siblings' peerDependencies requirements!

npm ERR! peerinvalid Peer [email protected] wants [email protected]>=1.0.0

npm ERR! peerinvalid Peer [email protected] wants [email protected]>=1.0.0-rc.1

npm ERR! peerinvalid Peer [email protected] wants [email protected]>=1.2.0

npm ERR! peerinvalid Peer [email protected] wants [email protected]>=1.0.0

npm ERR! peerinvalid Peer [email protected] wants [email protected]>=1.0.0

npm ERR! peerinvalid Peer [email protected] wants [email protected]>=1.0.0-rc.1.1

npm ERR! peerinvalid Peer [email protected]0.0 wants [email protected]>=1.0.0

npm ERR! peerinvalid Peer [email protected] wants [email protected]>=1.0.0

npm ERR! System Windows_NT 6.1.7601

npm ERR! command "C:\\Program Files\\nodejs\\\\node.exe" "C:\\Program Files\\nodejs\\node_modules\\npm\\bin\\npm-cli.js" "install" "-g" "yo"

npm ERR! cwd C:\Users\zmacomber\git

npm ERR! node -v v0.10.18

npm ERR! npm -v 1.3.8

npm ERR! code EPEERINVALID

npm ERR!

npm ERR! Additional logging details can be found in:

npm ERR! C:\Users\zmacomber\git\npm-debug.log

npm ERR! not ok code 0

网友答案:

You may need to update nodejs to be able to install the 1.2.0 version of yo.

相关阅读:
Top