问题描述:

I just installed the emacs-starter-kit into Debian Wheezy with the emacs-snapshot. I am getting and error:

Loading /home/felixdz/.emacs.d/starter-kit-registers.el (source)...done

loaded /home/felixdz/.emacs.d/starter-kit-registers.el

../.emacs.d/starter-kit.el: `flet' is an obsolete macro (as of 24.3); use either `cl-flet' or `cl-letf'.

Loading /home/felixdz/.emacs.d/starter-kit.el (source)...done

loaded /home/felixdz/.emacs.d/starter-kit.el

For information about GNU Emacs and the GNU system, type C-h C-a.

Package assoc is obsolete!

How do I fix this error? I am a completer beginner with Emacs.

网友答案:

It's not really an error, but a warning. And it's not aimed at you but at the package maintainers of some package that you load from the starter kit.

The point is that there's a vanilla Emacs 24.3, which doesn't give warnings, and then there are various libraries written for earlier versions of Emacs that you're using for Emacs 24.3. Hence the warnings.

It will still work for now, but probably when the next Emacs comes out the assoc package will produce an error instead of a warning like now.

You can choose now if you want the emacs-starter-kit or vanilla Emacs or something else. I learned my way from vanilla Emacs, doing the customizations myself.

相关阅读:
Top