问题描述:

The Setup:

I'm trying to install ColdFusion 9 on Ubuntu 14.04 with Apache 2.4.7. Seriously. Don't ask.

  • Spun up a Vagrant Box (xplore/ubuntu-14.04) that has the LAMP stack installed;
  • Performed apt-get update and apt-get upgrade;
  • Installed libstdc++5 (but still got a warning that CF couldn't verify it was installed);
  • Installed CF from ColdFusion_9_WWEJ_linux64.bin.

I had to create a symlink to /etc/apache2/apache2.conf called /etc/apache2/httpd.conf in order to get CF installed, because CF9 doesn't allow you to specify an apache config filename, but other than that everything went smoothly.

The Problem:

When I start CF using ./opt/coldfusion9/bin/coldfusion start I get this message:

There was an error while running the connector wizard

Connector installation was not successful

...which is the result of cf-connectors.sh modifying my apache2.conf, telling it to load the module /opt/coldfusion9/runtime/lib/wsconfig/1/mod_jrun22.so, then attempting to restart Apache and failing due to this error:

apache2: Syntax error on line 223 of /etc/apache2/apache2.conf:

Cannot load /opt/coldfusion9/runtime/lib/wsconfig/1/mod_jrun22.so into server:

/opt/coldfusion9/runtime/lib/wsconfig/1/mod_jrun22.so:

undefined symbol: ap_log_error

Troubleshooting Steps Taken:

I tailed the Apache error log, but that wasn't much help:

[mpm_prefork:notice] [pid 1516] AH00173: SIGHUP received. Attempting to restart

[mpm_prefork:notice] [pid 1516] AH00163: Apache/2.4.7 (Ubuntu) PHP/5.5.9-1ubuntu4.3 configured -- resuming normal operations

[core:notice] [pid 1516] AH00094: Command line: '/usr/sbin/apache2'

The JRun binary file does exist, in /opt/coldfusion9/runtime/bin/jrun. However, I've seen tutorials like this one that show it being located in /opt/jrun4...which is weird because my version of CF9 is referencing mod_jrun22.so, leading me to believe there is a version difference.

Running ./opt/coldfusion9/runtime/bin/jrun status, I get this output:

The coldfusion server is running

No jndi.properties file was found in samples's SERVER-INF directory. The JRun kernel requires JNDI information.

The samples server is not running

The admin server is not running

...which tells me that there is a missing indi.properties file, and that the samples and admin servers are not running. I assume that is a result of cf-connectors.sh failing.

The Question:

How can I get the CF connector wizard to succeed? What am I missing here?

Thanks in advance!

网友答案:

Apache 2.4.x is not supported by Coldfusion 9, see my answer here: Apache won't start with ColdFusion 10: mod_jk.conf procedure not found

I suggest you install Apache 2.2 and then you should be able to install the Connector.

网友答案:

While Apache 2.4 is not supported by Adobe, it is possible to get it running but recompiling the mod_jrun module against the Apache 2.4 sources (after a small modification to the source code).

There are full instructions on my blog post, if you're still interested.

mod_jrun on Apache 2.4 (Ubuntu 14.04 + ColdFusion 9)

相关阅读:
Top