问题描述:

My bower package sass-smacss:

https://github.com/leongaban/sass-smacss

And my bower.json file:

{

"name": "sass-smacss",

"version": "1.0.0",

"description": "SMACSS based SASS modules for organized style writing",

"homepage": "https://github.com/leongaban/sass-smacss",

"main": "sass/main_web.scss",

"authors": [

{

"name": "Leon Gaban",

"email": "[email protected]",

"homepage": "http://leongaban.com",

"twitter": "@leongaban"

}

],

"repository": {

"type": "git",

"url": "https://github.com/leongaban/sass-smacss.git"

},

"keywords": [

"sass",

"css",

"smacss",

"stylesheets"

],

"license": "MIT",

"ignore": [

"**/.*",

"bower.json",

"bower_components"

]

}

Looks like I was able to bower register it, however when I run bower info sass-smacss I get No versions available, and it's not found on Bower's packages search.

Followed instructions from:

http://bower.io/docs/creating-packages/

http://bob.yexley.net/creating-and-maintaining-your-own-bower-package/


UPDATE

Thanks @drorb I added a git tag. However after registering it again, still getting the No versions available message :(

I did git tag -a v1.0.0 -m 'First version'

网友答案:

Bower package versions are based on Git tags. In your case the sass-smacss Git repository does not contain any tag (only a master branch).
Also notice that tag names (effectively version names) must follow semver semantics.

相关阅读:
Top