问题描述:

Im trying to get crossroads.js working with require.js, being new to both projects. Crossroads keeps failing because its signal dependency is passed as undefined. Is there a bug in a project, or am I doing something wrong?

Here's a jsfiddle: http://jsfiddle.net/zkemk/2/

Check the console log.

This might be a duplicate, but Im not sure because the question seems dead and not very well described: Crossroads.js and require.js

网友答案:

The JS-Signals version on the "lib" folder of the Crossroads project is outdated, it doesn't call define() that's why it fails (v0.7+ calls define). I updated the jsfiddle to link to the newest version of signals and it works as expected: http://jsfiddle.net/zkemk/3/ - I will update the file on the Crossroads repository as well. Sorry for the inconvenience.

相关阅读:
Top