问题描述:

We are running ILMerge as a post build step and having problems when building on a Windows 8 machine.

ILMerge.exe is a .NET 2 application so should be able to be loaded/hosted within the .NET 4 runtime. However as soon as we try to execute ILMerge on a Windows 8 build machine the Windows Features dialog appears saying it can't automatically install .NET 3.5 (inc 2.0) and the command fails.

This also occurs if I simply run ILMerge.exe /? on the command line.

I've tried adding an app.config file with supportedRuntime/requiredRuntime but no luck. Does anyone know how I can resolve this problem whilst not installing .net 3.5 on the box.

Thanks

-- UPDATE ---

Having correctly added the app.config - ILMerge begins execution but fails with "Unable to load DLL 'mscorsn.dll': The specified module cannot be found.

Just prior to this message, Windows8 again prompts for .NET 3.5 (inc 2.0) to be installed.

网友答案:

The ILMerge tool is re-written with .NET 4.0 compatibility and they call it Gilma. Here is the link: http://www.codeproject.com/Articles/17797/Gilma-GUI-for-the-ILMerge-Application-Revised-for

I am not very sure whether it will work on Windows 8 or not but I hope it does. :)

相关阅读:
Top