问题描述:

Something absolutely bizarre began occurring in my ASP 4 application about a month ago with the advent of one of the later releases of Chrome 26, and has continued to be an issue in all builds of Chrome 27 to date. One of my co-workers reported that when he used this application via Chrome, many of the buttons (it turns out they were all the postbacks on the page) stopped working. I began testing older versions of the app to see if I could pinpoint where I might have gone wrong and it turns out that ALL previous builds were now exhibiting the same behavior. We were able to find a PC whose Chrome browser had not been automatically updated and behold, we could not replicate the issue on there!

When this state occurs, all postback buttons and links become completely dead. They visually behave as if they've been clicked but nothing happens behind the scenes. No Javascript calls, nothing! It's as if the buttons are simply disabled in the eyes of Chrome.

This week, I finally figured out the key to make the issue occur and stop. When I clear saved passwords from Chrome, postbacks are restored. As long as I don't allow Chrome to re-save my password, the application and all its postbacks work fine. As soon as I save the password again, I'm dead in the water within the next few clicks (yes, the postbacks DO continue working for a short time).

To make things even more bizarre, traditional hyperlinks and non-doPostBack JavaScript onclick's are not affected by this issue.

Any thoughts on what kind of code in my app could be causing this behavior? I'm not even sure where to begin!

相关阅读:
Top