问题描述:

VS 2013 Professional - Version 12.0.31101.00 Update 4

All of a sudden, whenever I try to open a project (MVC project or Python project), I get:

The 'ProviderPackage' package did not load correctly.

The problem

may have been caused by a configuration change or by the installation

of another extension. You can get more information by examining the

file

'C:\Users\xxxx\AppData\Roaming\Microsoft\VisualStudio\12.0\ActivityLog.xml'.

In my AppData\Roaming, there is no 12.0 folder! In AppData\Local, there is a 12.0 folder but there is no ActivityLog.xml file.

When I ignore the message and press F5 to run, after lots of disk movement, Visual Studio simply closes and disappears.

I have repaired a few times and the exact same behavior persists.

When I try to run devenv.exe /setup or devenv.exe /resetuserdata, absolutely nothing happens. No error, no process is launched, nothing. Running devenv.exe without any parameters does launch VS.

What can be wrong? I hesitate to uninstall and reinstall if there is some other solution.


1 day later: Uninstalled VS 2013 and reinstalled, and then applied Update 4.

Problem is still the same for the MVC project: ProviderPackage did not load correctly, and when running project VS closes and disappears.

Last record in ActivityLog.xml says:

<entry>

<record>1120</record>

<time>2015/03/17 06:38:43.882</time>

<type>Error</type>

<source>VisualStudio</source>

<description>An exception was thrown during package instantiation and was caught in the package manager [ProviderPackage]</description>

<guid>{5F2E5E42-4192-4D79-A0D8-1D881E808829}</guid>

<hr>8000ffff - E_UNEXPECTED</hr>

<errorinfo></errorinfo>

</entry>

网友答案:

Deleting ComponentModelCache from C:\Users\YourUserName\AppData\Local\Microsoft\VisualStudio\14.0\ComponentModelCache works fine for VS 2015. Note: You will need to close the VS before deleting this folder. Also replace 14.0 with 12.0 for VS 2013

网友答案:

Delete folder ComponenModelCache

C:\Users\XXXX\AppData\Local\Microsoft\VisualStudio\XX\ComponentModelCache

that worked for me

网友答案:

Start>Run and use the following commands (if necessary, change the directory according to the installation folder):

cd c:\
c:\>"C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\IDE\devenv.exe" /resetskippkgs"

Hope this helps...

相关阅读:
Top