View requires API level 14 (current min is 8)

来源:互联网 时间:1970-01-01

<GridLayout
        android:columnCount="4"
        android:layout_width="wrap_content"
        android:layout_height="wrap_content"
        android:id="@+id/gridContainer"
        android:animateLayoutChanges="true"

        />

When I change android:columnCount="4" to android:columnCount="5" , eclipse show the error "Type View requires API level 14 (current min is 4): <GridLayout>" .

或者用

<Switch

        android:id="@+id/switch1"

        android:layout_width="wrap_content"

        android:layout_height="wrap_content"

        android:text="Switch" />

时也报类似错误,因为版本过低

Solution : just 把Manifest.xml中的<uses-sdk android:minSdkVersion="10" />改的高些试试 ,然后clean the project and rebuilt it .​



相关阅读:
Top