装了ORACLE后,ECLIPSE启不起来了。

来源:互联网 时间:1970-01-01

以前在机子上运行挺好的,但自从我装了ORACLE之后,就出现了问题
Required Java version:1.4.1. Available:1.3.1+01

原因分析:估计ORACLE自己带了个低版本的jre,
解决办法:
1.COPY一份JRE到eclipse的下面,就可以了
注意,拷到eclipse根目录下,并且jre目录只要命名为jre
而不要是jre1.5.0_06

2.点击java->Installed JREs,然后显示如上,如果是初始安装的,只有显示第一个jre(不要问我什么是jre,自己查资料去),那是系统默认的安装在c盘的jre,如果系统当中安装了多个jdk,那么最好还是新建一个,点击add,然后选择你需要使用的jdk的位置,然后它会自动寻找其他的参数,点击ok。返回界面之后,不要忘记点选刚刚添加的jdk,要不然是没有用的。然后点击ok关闭这个窗口。

最根本的办法,就是将path中的oracle的jre全部换成你jdk中的地址.
C:/Program Files/Oracle/jre/1.3.1/bin;
C:/Program Files/Oracle/jre/1.1.8/bin;
换成
C:/Program Files/Java/jre1.5.0_06/bin;



相关阅读:
Top